A lot of script-driven apps, particularly paid content management systems, encode their files to ensure that they won't be reverse engineered or tampered with. The majority of them use an application known as ionCube PHP Encoder to do that, so, in case you get a paid script and you want to set it up in a web hosting account, a tool called ionCube Loader has to be present on your server. Without this, you will not be able to install the script or if you somehow manage to do this, it won't operate efficiently due to the fact that almost all of the script code will be encoded to a point where it cannot be interpreted. That is why, you need to ensure that ionCube Loader is set up if you get a new website hosting account and you'd like to use some paid web application. If you acquire a shared hosting account and the tool is not present, it cannot be added since the whole server PHP environment shall have to be compiled again.

IonCube in Website Hosting

When you buy a Linux website hosting from our company, it will be created on our custom-made cloud hosting platform where ionCube Loader is already present, so you will not have any kind of problems to manage any script app that needs the tool to function appropriately. In addition, we supply several different versions of PHP, so in case you change the version, you'll need to enable ionCube once again. Our system remembers the changes you make, so in case you go back to the earlier release of PHP which was active for your account, ionCube Loader will already be turned on. Both the PHP version and the ionCube tool can be operated through the PHP Configuration part of our Hepsia web hosting Control Panel. Each adjustment that you do takes literally just a click and it will take effect right away.

IonCube in Semi-dedicated Hosting

In case you obtain a semi-dedicated server package from us, you can employ any script-driven application that needs ionCube Loader as the tool is installed on all of the servers that are a part of our cutting-edge cloud hosting platform. We also support multiple releases of PHP, therefore if you move from PHP 4 to 5.2 or 5.3, for instance, you can enable ionCube for this particular release with only a click in your Hepsia Control Panel. Our system will remember your choice, so in case you move back to the previous release of PHP, the software tool will already be active. For more tech-savvy users, we also offer the option to pick the PHP version and if ionCube will be active or not for a particular domain without altering the settings for the whole hosting account. This can be done by putting a php.ini file in a domain folder with a couple of lines of code.